# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!.*\*\*$)(?!.{9})(?:[A-Za-z]{2}(?:\d*(?:\*\d*)+|\d{6})|\*)$"
test_str = ("RIGHT:\n"
"*\n"
"DE*\n"
"de*\n"
"GB5*\n"
"gb5*\n"
"DE*123\n"
"DE**123\n"
"de*123\n"
"DE123456\n\n"
"WRONG:\n"
"**\n"
"*DE\n"
"*de\n"
"D\n"
"D*\n"
"D**\n"
"d*\n"
"DE\n"
"DE123\n"
"DE123**\n"
"de\n"
"D1*\n"
"1\n"
"1*\n"
"123*\n"
"1234\n"
"DE1234567\n"
"DE123456*")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.