const regex = /^(?!.*\*\*$)(?!.{9})(?:[A-Za-z]{2}(?:\d*(?:\*\d*)+|\d{6})|\*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\*\\*$)(?!.{9})(?:[A-Za-z]{2}(?:\\d*(?:\\*\\d*)+|\\d{6})|\\*)$', 'gm')
const str = `RIGHT:
*
DE*
de*
GB5*
gb5*
DE*123
DE**123
de*123
DE123456
WRONG:
**
*DE
*de
D
D*
D**
d*
DE
DE123
DE123**
de
D1*
1
1*
123*
1234
DE1234567
DE123456*`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}