#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^]d2(?:" & @CRLF & _
"01(?P<g01>.{14})|" & @CRLF & _
"10(?P<g10>(?:(?!\[GS]).){1,20})(?:\[GS]|$)|" & @CRLF & _
"17(?P<g17>.{6})|" & @CRLF & _
"21(?P<g21>(?:(?!\[GS]).){1,20})(?:\[GS]|$)" & @CRLF & _
")+$"
Local $sString = "]d2010704626096200210KT0BT2204[GS]1726090021RNM5F8CTMMBHZSY7]" & @CRLF & _
"]d201070462608682672140097289158930[GS]10101656[GS]17261130"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")