package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^]d2(?:
01(?P<g01>.{14})|
10(?P<g10>(?:(?!\[GS]).){1,20})(?:\[GS]|$)|
17(?P<g17>.{6})|
21(?P<g21>(?:(?!\[GS]).){1,20})(?:\[GS]|$)
)+$`)
var str = `]d2010704626096200210KT0BT2204[GS]1726090021RNM5F8CTMMBHZSY7]
]d201070462608682672140097289158930[GS]10101656[GS]17261130`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}