using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^]d2(?:
01(?P<g01>.{14})|
10(?P<g10>(?:(?!\[GS]).){1,20})(?:\[GS]|$)|
17(?P<g17>.{6})|
21(?P<g21>(?:(?!\[GS]).){1,20})(?:\[GS]|$)
)+$";
string input = @"]d2010704626096200210KT0BT2204[GS]1726090021RNM5F8CTMMBHZSY7]
]d201070462608682672140097289158930[GS]10101656[GS]17261130";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}