import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^]d2(?:\n"
+ "01(?P<g01>.{14})|\n"
+ "10(?P<g10>(?:(?!\\[GS]).){1,20})(?:\\[GS]|$)|\n"
+ "17(?P<g17>.{6})|\n"
+ "21(?P<g21>(?:(?!\\[GS]).){1,20})(?:\\[GS]|$)\n"
+ ")+$";
final String string = "]d2010704626096200210KT0BT2204[GS]1726090021RNM5F8CTMMBHZSY7]\n"
+ "]d201070462608682672140097289158930[GS]10101656[GS]17261130";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}