using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[#$][^\s$#]+(?=(?:\s+[^\w\s]\S*)*\s*$)";
string substitution = @"";
string input = @"The moment #BTC, we have all $BTC been waiting for:We are happy to announce NIX Platform is rebranding to.. $NBT > $VOICE $NIX > $MUTE $ETH $BTC #BTC";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}