const regex = /[#$][^\s$#]+(?=(?:\s+[^\w\s]\S*)*\s*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[#$][^\\s$#]+(?=(?:\\s+[^\\w\\s]\\S*)*\\s*$)', 'gm')
const str = `The moment #BTC, we have all \$BTC been waiting for:We are happy to announce NIX Platform is rebranding to.. \$NBT > \$VOICE \$NIX > \$MUTE \$ETH \$BTC #BTC`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);