$re = '/[#$][^\s$#]+(?=(?:\s+[^\w\s]\S*)*\s*$)/m';
$str = 'The moment #BTC, we have all $BTC been waiting for:We are happy to announce NIX Platform is rebranding to.. $NBT > $VOICE $NIX > $MUTE $ETH $BTC #BTC';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;