use strict;
my $str = 'The moment #BTC, we have all $BTC been waiting for:We are happy to announce NIX Platform is rebranding to.. $NBT > $VOICE $NIX > $MUTE $ETH $BTC #BTC';
my $regex = qr/[#$][^\s$#]+(?=(?:\s+[^\w\s]\S*)*\s*$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";