re = /[#$][^\s$#]+(?=(?:\s+[^\w\s]\S*)*\s*$)/m
str = 'The moment #BTC, we have all $BTC been waiting for:We are happy to announce NIX Platform is rebranding to.. $NBT > $VOICE $NIX > $MUTE $ETH $BTC #BTC'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result