# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<ApplicationPath>.*\\West\\.*<\\/ApplicationPath>\n)<CommandLine \\/>/$1<CommandLine>trees -nowindow<\/CommandLine>/gm;t' <<< "<ApplicationPath>F:\Objects\Trees\Conifers\North America\West\comporgel.zip</ApplicationPath>
<CommandLine />
<ApplicationPath>F:\Objects\Trees\Conifers\North America\West\Christmas.zip</ApplicationPath>
<Photo />
<ApplicationPath>F:\Objects\Trees\Conifers\North America\West\spruce1.zip</ApplicationPath>
<CommandLine />
<ApplicationPath>F:\Objects\Trees\Conifers\North America\East\spruce1.zip</ApplicationPath>
<CommandLine />"