// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(<ApplicationPath>.*\\West\\.*<\/ApplicationPath>\n)<CommandLine \/>").unwrap();
let string = "<ApplicationPath>F:\\Objects\\Trees\\Conifers\\North America\\West\\comporgel.zip</ApplicationPath>
<CommandLine />
<ApplicationPath>F:\\Objects\\Trees\\Conifers\\North America\\West\\Christmas.zip</ApplicationPath>
<Photo />
<ApplicationPath>F:\\Objects\\Trees\\Conifers\\North America\\West\\spruce1.zip</ApplicationPath>
<CommandLine />
<ApplicationPath>F:\\Objects\\Trees\\Conifers\\North America\\East\\spruce1.zip</ApplicationPath>
<CommandLine />";
let substitution = "$1<CommandLine>trees -nowindow</CommandLine>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}