use strict;
my $str = '<ApplicationPath>F:\\Objects\\Trees\\Conifers\\North America\\West\\comporgel.zip</ApplicationPath>
<CommandLine />
<ApplicationPath>F:\\Objects\\Trees\\Conifers\\North America\\West\\Christmas.zip</ApplicationPath>
<Photo />
<ApplicationPath>F:\\Objects\\Trees\\Conifers\\North America\\West\\spruce1.zip</ApplicationPath>
<CommandLine />
<ApplicationPath>F:\\Objects\\Trees\\Conifers\\North America\\East\\spruce1.zip</ApplicationPath>
<CommandLine />';
my $regex = qr/(<ApplicationPath>.*\\West\\.*<\/ApplicationPath>\n)<CommandLine \/>/mp;
my $subst = '$1<CommandLine>trees -nowindow</CommandLine>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";