re = /(<ApplicationPath>.*\\West\\.*<\/ApplicationPath>\n)<CommandLine \/>/m
str = '<ApplicationPath>F:\\Objects\\Trees\\Conifers\\North America\\West\\comporgel.zip</ApplicationPath>
<CommandLine />
<ApplicationPath>F:\\Objects\\Trees\\Conifers\\North America\\West\\Christmas.zip</ApplicationPath>
<Photo />
<ApplicationPath>F:\\Objects\\Trees\\Conifers\\North America\\West\\spruce1.zip</ApplicationPath>
<CommandLine />
<ApplicationPath>F:\\Objects\\Trees\\Conifers\\North America\\East\\spruce1.zip</ApplicationPath>
<CommandLine />'
subst = '$1<CommandLine>trees -nowindow</CommandLine>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result