import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<ApplicationPath>.*\\\\West\\\\.*<\\/ApplicationPath>\\n)<CommandLine \\/>";
final String string = "<ApplicationPath>F:\\Objects\\Trees\\Conifers\\North America\\West\\comporgel.zip</ApplicationPath>\n"
+ "<CommandLine />\n"
+ "<ApplicationPath>F:\\Objects\\Trees\\Conifers\\North America\\West\\Christmas.zip</ApplicationPath>\n"
+ "<Photo />\n"
+ "<ApplicationPath>F:\\Objects\\Trees\\Conifers\\North America\\West\\spruce1.zip</ApplicationPath>\n"
+ "<CommandLine />\n"
+ "<ApplicationPath>F:\\Objects\\Trees\\Conifers\\North America\\East\\spruce1.zip</ApplicationPath>\n"
+ "<CommandLine />";
final String subst = "$1<CommandLine>trees -nowindow</CommandLine>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}