using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\([^)]*(?=,)";
string substitution = @"";
string input = @"George Peppard (John 'Hannibal' Smith), Dirk Benedict (Templeton 'Faceman' Peck), Dwight Schultz ('Howling Mad' Murdock), Mr T (Bfdsafd fdsafd, fdsa(fds fdsa), ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}