import re
regex = re.compile(r"\([^)]*(?=,)")
test_str = "George Peppard (John 'Hannibal' Smith), Dirk Benedict (Templeton 'Faceman' Peck), Dwight Schultz ('Howling Mad' Murdock), Mr T (Bfdsafd fdsafd, fdsa(fds fdsa), "
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)