$re = '/\([^)]*(?=,)/';
$str = 'George Peppard (John \'Hannibal\' Smith), Dirk Benedict (Templeton \'Faceman\' Peck), Dwight Schultz (\'Howling Mad\' Murdock), Mr T (Bfdsafd fdsafd, fdsa(fds fdsa), ';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;