re = /\([^)]*(?=,)/
str = 'George Peppard (John \'Hannibal\' Smith), Dirk Benedict (Templeton \'Faceman\' Peck), Dwight Schultz (\'Howling Mad\' Murdock), Mr T (Bfdsafd fdsafd, fdsa(fds fdsa), '
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result