import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\([^)]*(?=,)";
final String string = "George Peppard (John 'Hannibal' Smith), Dirk Benedict (Templeton 'Faceman' Peck), Dwight Schultz ('Howling Mad' Murdock), Mr T (Bfdsafd fdsafd, fdsa(fds fdsa), ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}