# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(:(?![\n])[()#$@-\w]+:)//g;t' <<< ":any-non-whitespace:
:text1:sample2:
:@(1@#$@SD: :s:
:nospace::inbetween: because there are 2 colons in the middle
:nospace:middle:nospace:
"