re = /(:(?![\n])[()#$@-\w]+:)/
str = ':any-non-whitespace:
:text1:sample2:
:@(1@#$@SD: :s:
:nospace::inbetween: because there are 2 colons in the middle
:nospace:middle:nospace:
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result