import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(:(?![\\n])[()#$@-\\w]+:)";
final String string = ":any-non-whitespace:\n"
+ ":text1:sample2:\n"
+ ":@(1@#$@SD: :s:\n"
+ ":nospace::inbetween: because there are 2 colons in the middle\n"
+ ":nospace:middle:nospace:\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}