const regex = /(:(?![\n])[()#$@-\w]+:)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(:(?![\\n])[()#$@-\\w]+:)', 'g')
const str = `:any-non-whitespace:
:text1:sample2:
:@(1@#\$@SD: :s:
:nospace::inbetween: because there are 2 colons in the middle
:nospace:middle:nospace:
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);