package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\p{Lu}\p{Ll}+(?:(?:\h(?:e|d(?:[ao]s|[aeo])))?\h\p{Lu}\p{Ll}+)+$`)
var str = `Paulo César Oliveira
Antonio Carlos da Silva
João da Silva dos Santos e Souza`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}