re = /^\p{Lu}\p{Ll}+(?:(?:\h(?:e|d(?:[ao]s|[aeo])))?\h\p{Lu}\p{Ll}+)+$/m
str = 'Paulo César Oliveira
Antonio Carlos da Silva
João da Silva dos Santos e Souza'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end