$re = '/^\p{Lu}\p{Ll}+(?:(?:\h(?:e|d(?:[ao]s|[aeo])))?\h\p{Lu}\p{Ll}+)+$/m';
$str = 'Paulo César Oliveira
Antonio Carlos da Silva
João da Silva dos Santos e Souza';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);