const regex = /^\p{Lu}\p{Ll}+(?:(?:\h(?:e|d(?:[ao]s|[aeo])))?\h\p{Lu}\p{Ll}+)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\p{Lu}\\p{Ll}+(?:(?:\\h(?:e|d(?:[ao]s|[aeo])))?\\h\\p{Lu}\\p{Ll}+)+$', 'gm')
const str = `Paulo César Oliveira
Antonio Carlos da Silva
João da Silva dos Santos e Souza`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}