import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\p{Lu}\\p{Ll}+(?:(?:\\h(?:e|d(?:[ao]s|[aeo])))?\\h\\p{Lu}\\p{Ll}+)+$";
final String string = "Paulo César Oliveira\n\n"
+ "Antonio Carlos da Silva\n"
+ "João da Silva dos Santos e Souza";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}