#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)([^:#\s.]+)(?:.*?)?\s*({[^}]*?})"
Local $sString = ".className { " & @CRLF & _
" some data here;" & @CRLF & _
" some data here;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"className {" & @CRLF & _
" some data here;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"#className {" & @CRLF & _
" some data here;" & @CRLF & _
"}" & @CRLF & _
"tagName1 {" & @CRLF & _
" some data here;" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"#tagName2 {" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
".tagName3:hover {" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
".tagName4:anything {" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")