import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^:#\\s.]+)(?:.*?)?\\s*(\\{[^\\}]*?\\})";
final String string = ".className { \n"
+ " some data here;\n"
+ " some data here;\n"
+ "}\n\n"
+ "className {\n"
+ " some data here;\n"
+ "}\n\n"
+ "#className {\n"
+ " some data here;\n"
+ "}\n"
+ "tagName1 {\n"
+ " some data here;\n"
+ "}\n\n"
+ "#tagName2 {\n"
+ "}\n\n"
+ ".tagName3:hover {\n"
+ "}\n\n"
+ ".tagName4:anything {\n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}