using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^:#\s.]+)(?:.*?)?\s*({[^}]*?})";
string input = @".className {
some data here;
some data here;
}
className {
some data here;
}
#className {
some data here;
}
tagName1 {
some data here;
}
#tagName2 {
}
.tagName3:hover {
}
.tagName4:anything {
}";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}