$re = '/([^:#\s.]+)(?:.*?)?\s*({[^}]*?})/s';
$str = '.className {
some data here;
some data here;
}
className {
some data here;
}
#className {
some data here;
}
tagName1 {
some data here;
}
#tagName2 {
}
.tagName3:hover {
}
.tagName4:anything {
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);