package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)([^:#\s.]+)(?:.*?)?\s*({[^}]*?})`)
var str = `.className {
some data here;
some data here;
}
className {
some data here;
}
#className {
some data here;
}
tagName1 {
some data here;
}
#tagName2 {
}
.tagName3:hover {
}
.tagName4:anything {
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}