using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[+-]?\d+(?:\.\d+)?";
string substitution = @" ";
string input = @"padding: 0;
font-size: 16pt;
width: 50%;
height: 20vh;
margin-right: 12px;
padding-right: -12.5px;";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}