import Foundation
let pattern = #"[+-]?\d+(?:\.\d+)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
padding: 0;
font-size: 16pt;
width: 50%;
height: 20vh;
margin-right: 12px;
padding-right: -12.5px;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)