# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[+-]?\d+(?:\.\d+)?"
test_str = ("padding: 0;\n"
"font-size: 16pt;\n"
"width: 50%;\n"
"height: 20vh;\n"
"margin-right: 12px;\n"
"padding-right: -12.5px;")
subst = " "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.