re = /[+-]?\d+(?:\.\d+)?/
str = 'padding: 0;
font-size: 16pt;
width: 50%;
height: 20vh;
margin-right: 12px;
padding-right: -12.5px;'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result