#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = " +([0-9]+ +){4}([a-z]+ [a-z]+) +(\/dev\/sd[a-z0-9]+)"
Local $sString = " Number Major Minor RaidDevice State" & @CRLF & _
" 0 8 1 0 active sync /dev/sda1" & @CRLF & _
" 4 8 144 0 spare rebuilding /dev/sdj" & @CRLF & _
" 1 8 97 1 active sync /dev/sdg1" & @CRLF & _
" 2 8 113 2 active sync /dev/sdh1" & @CRLF & _
" 3 8 81 3 active sync /dev/sdf1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")