import Foundation
let pattern = #" +([0-9]+ +){4}([a-z]+ [a-z]+) +(\/dev\/sd[a-z0-9]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Number Major Minor RaidDevice State
0 8 1 0 active sync /dev/sda1
4 8 144 0 spare rebuilding /dev/sdj
1 8 97 1 active sync /dev/sdg1
2 8 113 2 active sync /dev/sdh1
3 8 81 3 active sync /dev/sdf1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)