import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " +([0-9]+ +){4}([a-z]+ [a-z]+) +(\\/dev\\/sd[a-z0-9]+)";
final String string = " Number Major Minor RaidDevice State\n"
+ " 0 8 1 0 active sync /dev/sda1\n"
+ " 4 8 144 0 spare rebuilding /dev/sdj\n"
+ " 1 8 97 1 active sync /dev/sdg1\n"
+ " 2 8 113 2 active sync /dev/sdh1\n"
+ " 3 8 81 3 active sync /dev/sdf1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}