using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" +([0-9]+ +){4}([a-z]+ [a-z]+) +(\/dev\/sd[a-z0-9]+)";
string input = @" Number Major Minor RaidDevice State
0 8 1 0 active sync /dev/sda1
4 8 144 0 spare rebuilding /dev/sdj
1 8 97 1 active sync /dev/sdg1
2 8 113 2 active sync /dev/sdh1
3 8 81 3 active sync /dev/sdf1";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}