re = / +([0-9]+ +){4}([a-z]+ [a-z]+) +(\/dev\/sd[a-z0-9]+)/
str = ' Number Major Minor RaidDevice State
0 8 1 0 active sync /dev/sda1
4 8 144 0 spare rebuilding /dev/sdj
1 8 97 1 active sync /dev/sdg1
2 8 113 2 active sync /dev/sdh1
3 8 81 3 active sync /dev/sdf1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end