# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\s)(?=\[)/\n/gm;t' <<< "[json][17:50 timestamp] hello [mike18][18:06 timestamp] hi"