re = /(?<=\s)(?=\[)/m
str = '[json][17:50 timestamp] hello [mike18][18:06 timestamp] hi'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result