const regex = new RegExp('(?<=\\s)(?=\\[)', 'gm')
const str = `[json][17:50 timestamp] hello [mike18][18:06 timestamp] hi`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);