$re = '/(?<=\s)(?=\[)/m';
$str = '[json][17:50 timestamp] hello [mike18][18:06 timestamp] hi';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;