use strict;
my $str = '[json][17:50 timestamp] hello [mike18][18:06 timestamp] hi';
my $regex = qr/(?<=\s)(?=\[)/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";