#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w+(?: +\w+)+(?=\s*:\s*B)"
Local $sString = "Ronald Mayr: A" & @CRLF & _
"Bell Kassulke : B" & @CRLF & _
"Simon Loidl: B" & @CRLF & _
"" & @CRLF & _
"Надо сгенерировать список только тех, кто получил оценку В:" & @CRLF & _
"Bell Kassulke" & @CRLF & _
"Simon Loidl"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")